¿Cómo poner @ en un comentario dentro de un JCL?

Todo lo referido a automatizadores de consola u otros (CONTROL-O, System Automation, etc)
Responder
Avatar de Usuario
jjcvmadrid
Usuario
Usuario
Mensajes: 14
Registrado: 20 Jun 2008, 04:15
Ubicación: MADRID ESPAÑA

¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 28 Sep 2011, 12:04

Buenas tardes
me ha tocado hacer unos paneles informativos de los distintos clientes para soporte al operador
para ello he creado unos paneles informativos a través del Netview donde el operador con un comando de busqueda corto, recibe toda la información del cliente. ejemplo el operador da `p madagascar' ; pues sale toda la información referida a dicho cliente.
Mi problema es el siguiente, no me coje la @, asique de momento me estoy apañando con # , por ejemplo madagascar#yahoo.es
¿Podríais ayudarme cómo puedo poner la @ en el JCL? y que luego se refleje en el panel.

saludos
IT JS CPD

Avatar de Usuario
Vicente
Colaborador avanzado
Colaborador avanzado
Mensajes: 543
Registrado: 21 Jul 2011, 04:52
País: España
Ciudad: Malaga
Ocupación: Técnico en Sistemas

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por Vicente » 29 Sep 2011, 03:50

Hola:
Ninguno de los cuatro comentarios del siguiente JCL da error

//PRUEBA1 JOB CLASS=0,MSGCLASS=A,MSGLEVEL=(1,1)
/* C@R@COL@
//* HOLA C@R@COL@
//PASO1 EXEC PGM=IEFBR14 @@@@
//SYSPRINT DD SYSOUT=* B@B@ @@

Si puedes ser más explicito y escribir el trozo de jcl que te da el error, así como el mensaje de error, quizás pueda ayudarte más

Un saludo
Varios días probando, equivocandote y volviendo a probar
pueden ahorrarte quince minutos de lectura de un manual.

Avatar de Usuario
jjcvmadrid
Usuario
Usuario
Mensajes: 14
Registrado: 20 Jun 2008, 04:15
Ubicación: MADRID ESPAÑA

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 10:38

Hola
yo en jcl puedo poner @ en una ficha comentario pero el panel de netview no ve la @, sin embargo otros carácteres si salen

En el jcl
000017 $| telefonica@net.com
000018 $| telefonica#net.com
000019 $|
000020 $|
000021 $|

En el panel del netview

telefonica net.com
telefonica#net.com
IT JS CPD

Avatar de Usuario
jjcvmadrid
Usuario
Usuario
Mensajes: 14
Registrado: 20 Jun 2008, 04:15
Ubicación: MADRID ESPAÑA

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 10:41

Hola
yo en jcl puedo poner @ en una ficha comentario pero el panel de netview no ve la @, sin embargo otros carácteres si salen

En el jcl
000017 $| telefonica@net.com
000018 $| telefonica#net.com
000019 $|
000020 $|
000021 $|

En el panel del netview

telefonica net.com
telefonica#net.com
IT JS CPD

Avatar de Usuario
jjcvmadrid
Usuario
Usuario
Mensajes: 14
Registrado: 20 Jun 2008, 04:15
Ubicación: MADRID ESPAÑA

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 10:42

en la linea que sale @.com
estoy poniendo telefonica luego @ luego net luego.com
telefonica@net.com
IT JS CPD

Avatar de Usuario
Vicente
Colaborador avanzado
Colaborador avanzado
Mensajes: 543
Registrado: 21 Jul 2011, 04:52
País: España
Ciudad: Malaga
Ocupación: Técnico en Sistemas

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por Vicente » 30 Sep 2011, 04:34

Lo primero que hay que comprobar, con el mandato HEX ON del editor, es que @ es el código hexadecimal 7C, no vaya a ser que tengas el lenguage del teclado en el telnet mal.
Lo segundo, sería estudiar si @ es un caracter especial para Netview o su utilidad de paneles.
Varios días probando, equivocandote y volviendo a probar
pueden ahorrarte quince minutos de lectura de un manual.

Responder