Problema Host on Demand Telnet en z/OS v2.1

Todo lo relacionado con VTAM, TCP/IP, OSA/SF, configuración de placas OSA, VIPA, etc.
Responder
rojasoswaldo
Usuario
Usuario
Mensajes: 27
Registrado: 26 Mar 2012, 16:56
País: Venezuela
Ciudad: caracas
Ocupación: Jefe de grupo

Problema Host on Demand Telnet en z/OS v2.1

Mensaje por rojasoswaldo » 12 Sep 2016, 15:55

Buenas tardes,realizamos la migracion de S.O de 1.13 a V 2.1 pero tengo un problema con 4 puertos SSL y TLS que ahora no se conectan por el Keyring y el error que me da es el siguiente:
EZZ6034I TELNET CONN 00029E23 LU **N/A** CONN DROP ERR 600D 867
IP..PORT: 10.0.38.30..60280 EZBTPOSL
al revisar parece que es un problema con el SSL pues seguidamente me da el siguiente

RCODE: 600E-00 SSL/TLS handshake timed out.
PARM1: 000001F7 PARM2: 00000000 PARM3: GSK_SECURE_SOCKET_INIT

no se si es que con la version 2.1 existe algo nuevo para la generación de los certificados o algun parametro de SSL que pase por alto.

Matu19790
Usuario
Usuario
Mensajes: 1
Registrado: 12 Jul 2016, 18:09
País: Argentina
Ciudad: Buenos Aires
Ocupación: Administrador de Networking

Re: Problema Host on Demand Telnet en z/OS v2.1

Mensaje por Matu19790 » 02 Oct 2016, 18:28

Hola Rojasoswaldo, pudiste solucionar el tema ?
Sino es asi, te hago una pregunta. Qué versión de ssl/tls estas usando para en el HoD?
Usas Attls o TLS? Cambiaste algo en las políticas?
Si solucionaste el problema, podras comentar la solución?
Gracias
Saludos.

dzavala
Usuario
Usuario
Mensajes: 3
Registrado: 26 Ene 2015, 05:49
País: EE.UU
Ciudad: Dallas
Ocupación: System Programmer

Re: Problema Host on Demand Telnet en z/OS v2.1

Mensaje por dzavala » 03 Oct 2016, 00:26

Nosotros encontramos los vehiculos del TLS, con z/OS 2.2. Cambeamos a TSL2 y SHA correspondencia de certificados
al mismo tiempo cambeamos el RACF para los certificados del CICS utilizando Coupling Facility. Les mostrare un ejemplo:

ftorcal
Usuario
Usuario
Mensajes: 25
Registrado: 19 Abr 2010, 10:29
País: spain
Ciudad: madrid
Ocupación: IT Specialist

Re: Problema Host on Demand Telnet en z/OS v2.1

Mensaje por ftorcal » 14 Oct 2016, 17:29

Ese error es por los certificados añadidos a RACF, debes añadir el root CA y el intermediate

http://www-01.ibm.com/support/docview.w ... wg21180043

rojasoswaldo
Usuario
Usuario
Mensajes: 27
Registrado: 26 Mar 2012, 16:56
País: Venezuela
Ciudad: caracas
Ocupación: Jefe de grupo

Re: Problema Host on Demand Telnet en z/OS v2.1

Mensaje por rojasoswaldo » 24 Oct 2016, 14:54

Buenas resolvimos el problema de 2 formas la primera migramos el HOD a versión distribuida de window(Rational for Host on Demand v 8) y los certificados con TLS para RACF quitandolos del anillo de HFS que teniamos la version 6 de HOD en mainframe con TLS no nos funcionó con los certificados y el anillo de HFS ni RACF.

Gracias por su apoyo.

Responder